РУКОВОДСТВО ПОЛЬЗОВАТЕЛЯ

Министерство образования и науки РФ
Федеральное агентство по образованию
Омский государственный технический университет
Факультет информационных технологий и компьютерных систем
Кафедра автоматизации и робототехники

РУКОВОДСТВО ПОЛЬЗОВАТЕЛЯ

Мультимедийное приложение

к курсу лекций по дисциплине

«ПРОЕКТИРОВАНИЕ АВТОМАТИЗИРОВАННЫХ

СИСТЕМ»

Дипломная работа
студента группы ВА-612
Артемова Дмитрия Александровича


Открытие файлов

Файлы МП в формате EXE (исполняемые файлы) представляют собой программы готовые к непосредственному использованию и не требуют никаких дополнительных программ, библиотек, компонентов и др. Для использования остальных файлов МП требуются специальные программы.

Существует три способа позволяющих использовать такие файлы:

Первый способ. Открыть программу позволяющую работать с нужным файлом и уже из нее открыть этот файл. Например, для просмотра видео (формат MPEG) можно открыть видеопроигрыватель (программа Light Alloy) и из нее открыть файл (Рис. 2).

Открытие видео-файла в программе

Рис. 2

Второй способ. Можно воспользоваться контекстным меню файла (для этого нужно нажать на файл правой кнопкой мыши) и выбрать предлагаемые действия из списка. Например, воспроизвести (Рис. 3) или открыть с помощью…(Рис. 4).

Воспроизвести аудио-файл из контекстного меню

Рис. 3

Открыть HTML-документ через контекстное меню

Рис. 4

Третий способ. Если файл ассоциирован с программой, то можно сразу его запустить. «Ассоциирован с программой» значит – в системе имеются сведения о том, какой программой следует открывать файл определенного формата. Например, документ Microsoft Word (формат DOC) ассоциирован с программой Microsoft Office Word.

Если файл не ассоциирован с какой-либо программой, то иконка имеет вид изображенный на Рис. 5.

Иконка файла не ассоциированного с программой

Рис. 5

В этом случае можно воспользоваться предыдущими способами или ассоциировать файл с программой. Для этого нужно открыть свойства файла (пункт «Свойства» в контекстном меню файла).

Во вкладке «Общие» нажать на кнопку «Изменить» (Рис. 6 б).

Переход к свойствам файла

а)

б)

Рис. 6

В окне «Выбор программы» выбрать программу из списка или указать на расположение программы, нажав кнопку «Обзор…» (Рис. 7).

Список программ для открытия файла

Рис. 7

[ Начало ]


Мультимедийное приложение

Мультимедийное приложение (МП) предназначено для обучения студентов всех форм обучения специальности 220301 – «Автоматизация технологических процессов и производств», а также в качестве справочных материалов.

МП состоит из нескольких частей, характеризуемых следующими форматами файлов: SWF, EXE, HTML, MP3 и MPEG. Каждая часть расположена в отдельной папке (Рис. 1).

папка с файлами SWF папка с файлами EXE папка с файлами HTML папка с файлами MP3 папка с файлами MPEG2

Рис. 1

Состав МП:

1. Flash-лекции (формат SWF)

2. EXE-лекции (формат EXE)

3. HTML-лекции (формат HTML)

4. Аудио (формат MP3)

5. Видео (формат MPEG)


EXE-лекции (формат EXE)

2. EXE-лекции (формат EXE)

В папке

папка с файлами EXE

находятся нормативные документы, темы и меню выбора этих тем.

2.1. Системные требования

  • Pentium II 400 МГц и выше;
  • 64 Мб RAM и выше;
  • Разрешение 800х600 и выше;
  • Microsoft Windows 98SE, ME, NT, 2000, XP и поздние версии;
  • 49 Мбайт свободного места на диске.

2.2. Подготовка

Файлы в формате EXE являются исполняемыми, поэтому никакой подготовки не требуется.

2.3. Использование

Файлы в формате EXE получены в результате преобразования swf-файлов, их работа аналогична за исключение того, что темы, из программы просмотра тем, открываются в новом окне (см. Формат SWF). Иконки файлов имеют вид, изображенный на Рис. 2.1.

Иконки файлов в формате EXE

Рис. 2.1


Flash-лекции (формат SWF)

1. Flash-лекции (формат SWF)

В папке

папка с файлами SWF

находятся нормативные документы, темы и меню выбора этих тем.

1.1. Системные требования

  • Pentium II 400 МГц и выше;
  • 64 Мб RAM и выше;
  • Разрешение 800х600 и выше;
  • Совместимость с Adobe (Macromedia) Flash 7 и поздних версий;
  • 12 Мбайт свободного места на диске.

1.2. Подготовка

Файлы в формате SWF не являются исполняемыми, для работы с ними нужен специальный проигрыватель Flash Player или Интернет-браузер поддерживающий Flash. Иконка файла ассоциированного с проигрыватель может иметь вид, изображенный на Рис. 1.1.

Иконка файла в формате SWF

Рис. 1.1

1.3. Использование

Вы можете сразу открыть интересующую Вас тему, либо открыть «меню выбора тем» (файл ThemeViewer.swf). После открытия меню выбора тем Вы увидите заставку с информацией (Рис. 1.2).

Рис. 1.2

Для перехода к выбору тем нажмите кнопку «НАЧАТЬ».

Меню выбора тем

Рис. 1.3

Слева расположен список тем, а справа - название, краткая информация и кнопка для перехода к выбранной теме (Рис. 1.3). Для выбора темы нажмите на ее номер. После нажатия на кнопку «ПЕРЕЙТИ К ЭТОЙ ТЕМЕ» она открывается в этом же окне.

Рис. 1.4

После открытия темы Вы увидите заставку с информацией (Рис. 1.4). Для перехода к теме нажмите на кнопку «ТЕМА Х», где Х – номер темы. Если тема открыта из «меню выбора тем», то Вы сразу переходите к теме (без заставки).

Рис. 1.5

В окне темы вверху расположены номер и название темы, ниже - разделы темы (Рис. 1.5). Переход к разделу осуществляется нажатием на него.

Если тема открыта из «меню выбора тем», то для выбора другой темы нажмите на кнопку "Выбор темы" в правом верхнем углу.

Рис. 1.6

После выбора раздела происходит переход к интересующей Вас информации, которая представлена в виде кадров.

Вверху кадра располагается номер, и название раздела, в центре информация, а внизу панель навигации (Рис. 1.6).

Рис. 1.7

В панели навигации (Рис. 1.7) слева расположена информация о номере текущего кадра и общее число кадров в данном разделе; далее - кнопка для перехода к выбору разделов (меню темы); далее - кнопки для перехода на предыдущий и следующий кадр. Если текущий кадр - первый или последний в разделе, то при нажатии на одну из кнопок перехода осуществляется переход на предыдущий или следующий раздел соответственно (Рис. 1.8).

Рис. 1.8

В случае необходимости в левой нижней части окна отображается подсказка, указывающая на возможность взаимодействия с кадром (Рис. 1.9).

Подсказка в кадре

Рис. 1.9

В тексте имеются ссылки на нормативные документы, они выделены светло-синим цветом. Если нормативный документ выделен темно-синим цветом, то на него нет ссылки (такого документа в МП нет). При наведении мышки на ссылку, она подчеркивается (Рис. 1.10), при нажатии открывается документ в новом окне (Рис. 1.11).

Ссылка на ГОСТ в кадре

Рис. 1.10

Рис. 1.11


HTML-лекции (формат HTML)

3. HTML-лекции (формат HTML)

В папке

папка с файлами HTML

находятся нормативные документы, темы и меню выбора этих тем.

3.1. Системные требования

  • Pentium II 400 МГц и выше;
  • 64 Мб RAM и выше;
  • Разрешение 800х600 и выше;
  • Интернет-браузер (например, Internet Explorer);
  • 18 Мбайт свободного места на диске.

3.2. Подготовка

Файлы в формате HTML не являются исполняемыми, для работы с ними нужен Интернет-браузер. HTML-документы, как правило, уже ассоциированы с программой. Если эта программа – Internet Explorer, то иконка файла имеет вид, изображенный на Рис. 3.1.

Иконка файла в формате HTML

Рис. 3.1

3.3. Использование

Вы можете сразу открыть интересующую Вас тему, либо открыть «меню выбора тем» (файл ThemeViewer.htm). После открытия меню выбора тем Вы увидите список тем и нормативных документов, а также можете прочитать введение (Рис. 3.2).

Меню выбора тем и нормативных документов

Рис. 3.2

Ссылки в документе выделены синим цветом и шрифтом, отличающимся от остального текста. При наведении мыши на ссылку она подчеркивается и принимает оранжевый цвет (Рис. 3.3).

Ссылка на ГОСТ

а)

Ссылка на ГОСТ

б)

Рис. 3.3

Список темы и нормативных документов – ссылки. При нажатии на тему происходит переход к теме (Рис. 3.4), а при нажатии на нормативный документ – открытие его в новом окне.

Рис. 3.4

Внизу темы находятся две ссылки: переход к началу станицы – «Вверх» и переход в меню – «Меню».

Рис. 3.5

В темах имеются ссылки на рисунки и таблицы, находящиеся в них (Рис. 3.6).

Ссылка к рисунку

Рис. 3.6


Аудио (формат MP3)

4. Аудио (формат MP3)

В папке

находятся аудио-файлы, список и меню выбора этих файлов.

4.1. Системные требования

  • Pentium II 400 МГц и выше;
  • 64 Мб RAM и выше;
  • Разрешение 800х600 и выше;
  • Аудио-плеер (например, WinAmp);
  • 16 Мбайт свободного места на диске.

4.2. Подготовка

Файлы в формате MP3 не являются исполняемыми, для работы с ними нужен Аудио-плеер. Если эта программа – WinAmp, то иконка файла имеет вид, изображенный на Рис. 4.1.

Рис. 4.1

4.3. Использование

Вы можете сразу запустить интересующий Вас аудио-файл, воспользоваться «меню выбора аудио-файлов» (SoundViewer.htm), чтобы найти то, что нужно или воспользоваться списком (SoundList.m3u).

Аудио-файлы озвучивают некоторые темы. В меню находится список тем с разделами и ссылками на аудио-файлы (Рис. 4.2).

Рис. 4.2

После нажатия на ссылку в программе Internet Explorer появляется окно «Загрузка файла» (Рис. 4.3).

Рис. 4.3

При нажатии на кнопку «Открыть» откроется ассоциированная с файлом программа и запустит его (Рис. 4.4).

Рис. 4.4

Если открыть список, то откроется ассоциированный с ним аудио-плеер со списком всех аудио-файлов (Рис. 4.5).

Рис. 4.5


Видео (формат MPEG)

5. Видео (формат MPEG)

В папке

находятся видео-файлы, список и меню выбора этих файлов.

5.1. Системные требования

  • Pentium II 400 МГц и выше;
  • 64 Мб RAM и выше;
  • Разрешение 800х600 и выше;
  • Видеопроигрыватель (например, Light Alloy);
  • 256 Мбайт свободного места на диске.

5.2. Подготовка

Файлы в формате MPEG не являются исполняемыми, для работы с ними нужен видеопроигрыватель. Если эта программа – Light Alloy, то иконка файла имеет вид, изображенный на Рис. 5.1.

Рис. 5.1

5.3. Использование

Вы можете сразу запустить интересующий Вас видео-файл, воспользоваться «меню выбора видео-файлов» (VideoViewer.htm), чтобы найти то, что нужно или воспользоваться списком (VideoList.m3u). Видео-файлы показывают работу различных средств автоматизации.

В меню находится окно просмотра видео, список файлов и настройки воспроизведения (Рис. 5.2).

Рис. 5.2

Для просмотра видео выберите файл из списка и нажмите на кнопку «OK», можно также изменить размер видео или включить/отключить цикличное воспроизведение.

Если запустить список, то откроется ассоциированный со списком видеопроигрыватель со списком всех видео-файлов (Рис. 5.3).

Рис. 5.3